Back to overview
Downtime

Direct Premium Guest Vetting Unresponsive

Aug 18 at 06:18pm CEST
Affected services
Direct

Resolved
Aug 18 at 06:46pm CEST

This incident has been resolved. Guest Vetting requests are now working for Direct Premium reservations. Guests can now go through the verification process via their Guest Portal.

Updated
Aug 18 at 06:38pm CEST

The issue has been identified and a fix is being implemented.

Created
Aug 18 at 06:18pm CEST

Our Guest Vetting system for Direct Premium reservations is currently unresponsive for new reservations.

Our engineers are aware of this and are currently investigating the issue.