Back to overview
Downtime
Send button missing from guest conversation in Inbox
Aug 14, 2025 at 04:40pm UTC
Affected services
Inbox
Resolved
Aug 14, 2025 at 05:02pm UTC
This incident has been resolved.
Affected services
Created
Aug 14, 2025 at 04:40pm UTC
We introduced a bug that removed the send button. We are working on a fix now.
Affected services