Slow loading times on the Hospitable web application

Incident Report for Hospitable.com

Resolved

The connectivity issue with our upstream provider has been fully resolved. All services are operating normally again.
Posted Sep 24, 2025 - 12:02 UTC

Monitoring

We’re seeing improved performance as our upstream provider has mitigated the issue. Services should stabilize, but we continue to monitor closely until everything is fully resolved.
Posted Sep 24, 2025 - 10:22 UTC

Identified

Some of our services may be slower than usual due to a connectivity issue with an upstream provider. Their engineering team is actively rerouting traffic to restore stability.

We are monitoring the situation closely and will provide updates here as they become available.
Posted Sep 24, 2025 - 10:17 UTC
This incident affected: Channels (Booking.com API, Airbnb.com API, Vrbo API, Agoda API) and Our Websites (Web application (my.hospitable.com)).