Send button missing from guest conversation in Inbox

Incident Report for Hospitable.com

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 17:02 UTC

Identified

We introduced a bug that removed the send button. We are working on a fix now.
Posted Aug 14, 2025 - 16:40 UTC
This incident affected: Products & Features (Inbox).