Issues with rolling availability for Booking.com

Incident Report for Hospitable.com

Resolved

We've released a fix for the Availability Window issue affecting Booking.com listings and completed a calendar re-sync to restore the correct rolling availability settings.

All affected properties will automatically reflect the proper calendar state within the next 10 hours, as ongoing syncs are processed.

We’re continuing to monitor the rollout to ensure everything remains stable.
Posted Oct 25, 2025 - 14:44 UTC

Monitoring

We've implemented and released a fix for the Advanced Availability (Availability Window) issue affecting Booking.com listings. We're now performing a calendar re-sync to ensure all properties reflect the correct calendar state with the proper Availability Window settings applied.

Our team is closely monitoring the results to confirm that everything is working as expected.
Posted Oct 25, 2025 - 12:55 UTC

Identified

We've identified the issue and are working on releasing a fix
Posted Oct 25, 2025 - 12:12 UTC

Investigating

We are currently investigating reports of unexpected behavior in the Advanced Availability feature on Booking.com. Some hosts have reported receiving reservations further in advance than their configured time settings allow.

Our engineering team is actively looking into the issue and will provide an update once we have more information.
Posted Oct 25, 2025 - 10:35 UTC
This incident affected: Products & Features (Calendar).