Direct Premium Guest Verification

Incident Report for Hospitable.com

Resolved

This incident has been resolved.
Posted Feb 23, 2025 - 15:52 UTC

Investigating

We are experiencing issues with Direct Premium guest verification that causes the guests to be stuck on the selfie upload. We have extended the expiration of all bookings who are having issues by 12 hours. If you have a last-minute booking, please reach out to us through support@hospitable.com so we can assist with possible workarounds.
Posted Feb 23, 2025 - 13:38 UTC