Elevated Vrbo API Errors
Incident Report for Hospitable.com
Resolved
Stability has continued overnight and we are happy we have a solid connection again.

The team is continuing to monitor a very limited number of customers who may be experiencing a higher rate of errors and we will make adjustments accordingly to reduce these errors too.
Posted Jan 27, 2024 - 09:58 UTC
Update
Things have continued to remain stable throughout today - there are still a few occasional errors that we see but these are mostly due to our new configurations, we are aware and monitoring these and the team continues to fix those misconfigurations as they appear.

Thank you for standing strong whilst we dealt with these issues over the last week or so, both the engineering and support teams really appreciate the patience whilst we were working tirelessly to overcome these problems.
Posted Jan 26, 2024 - 15:09 UTC
Monitoring
The engineering team have made some further changes and we are seeing a recovery of the Vrbo API. We still need to continue monitoring to ensure that these changes do not become blocked again.

The majority of Vrbo API calls are successful, we are seeing a few Vrbo Channels seeing errors due to some issues with the new configurations we have deployed. We are aware of these and are collecting data on the affected accounts and will be making changes to bring those accounts back online again too.

Fingers crossed, Hospitable Hosts! 💜
Posted Jan 25, 2024 - 19:05 UTC
Update
Our Vrbo API continues to be blocked with only around 12-16% of requests being successful.

The engineering team is continuing to work on solutions and trying a number of different approaches to work around the issues faced.
Posted Jan 25, 2024 - 14:50 UTC
Identified
Unfortunately Vrbo has been able to block our requests again resulting in a partial outage. We are still seeing some request being successful.

Our engineering team is continuing efforts, and hadn't stopped, to work around these issues and restore a stable connection for our hosts.
Posted Jan 24, 2024 - 22:37 UTC
Update
We are continuing to see a consistently stable connection to the Vrbo API with no ongoing or intermittent issues since making our recent changes over 2 hours ago.
Posted Jan 24, 2024 - 20:11 UTC
Monitoring
We have been able stabilise the Vrbo API again. We are continuing to dedicate substantial engineering resources as a priority to retain a consistently stable Vrbo API connection.

For the technically inclined; We are aware we are occasionally being blocked by Vrbo in relation to how we make requests to their API, via
handshake fingerprinting and other data associated with the request and are actively working to mitigate this and improve the experience for hosts.
Posted Jan 24, 2024 - 13:00 UTC
Identified
We are continuing to work on a fix for this issue.
Posted Jan 24, 2024 - 04:41 UTC
Investigating
Vrbo is currently experiencing an elevated rate of API errors. We are monitoring the situation.

This is usually the case whenever Vrbo is under maintenance or is experiencing technical difficulties. Since Vrbo is partially unavailable during this time, this may affect our operations until Vrbo is back to normal.
Posted Jan 24, 2024 - 00:00 UTC
This incident affected: Channels (Vrbo API).