Issue preventing Metrics from loading for some hosts

Incident Report for Hospitable.com

Resolved

Metrics is fully operational. The incident has been resolved.
Posted Nov 15, 2025 - 06:32 UTC

Update

We are continuing to work on a fix for the metrics dashboard issue.
Posted Nov 15, 2025 - 05:27 UTC

Identified

We've identified an issue preventing Metrics from loading for many hosts. We are working to resolve this issue.
Posted Nov 14, 2025 - 23:23 UTC
This incident affected: Our Websites (Web application (my.hospitable.com)) and Products & Features ((Legacy) Metrics).