Back to overview
Resolved

Login & verification emails/SMS not delivering — investigating

Jul 26, 2026 at 3:14am UTC
Affected services
Web application (my.hospitable.com)

Resolved
Jul 26, 2026 at 6:25am UTC

We're no longer seeing delays from our mail delivery provider. Login related emails are now delivering as expected.

Created
Jul 26, 2026 at 3:14am UTC

Login and verification emails not delivered, customers can't access accounts because magic link email and pasword reset are not sending or are being delay for at least an hour. Detected July 25, 9:19 PM EDT.