Back to overview
Degraded

Database performance issues causing platform delays

Jun 26, 2026 at 1:33pm UTC
Affected services
Web application (my.hospitable.com)
Inbox
Guest experience
Reservations Sync
Datacenter

Resolved
Jun 26, 2026 at 2:01pm UTC

We have identified and resolved the issue. All delays should now be resolved.

Created
Jun 26, 2026 at 1:33pm UTC

We are experiencing database performance issues which may cause delays across parts of the platform, including scheduled message generation and inbox updates.

We have identified the issue and are working on a fix. Some features may appear delayed while we resolve this.

We will post updates here as we learn more.