Back to overview
Degraded

Degraded performance on Hospitable app

Jun 2, 2026 at 3:05pm UTC
Affected services
Web application (my.hospitable.com)

Resolved
Jun 2, 2026 at 5:21pm UTC

This incident has been resolved.

Created
Jun 2, 2026 at 3:05pm UTC

We're currently investigating reports of degraded performance and intermittent slowness in the Hospitable app. Some users may experience slow page loads or timeouts. Our engineering team is actively investigating and working on a fix. We'll share an update as soon as we have more information. Thank you for your patience.