Back to overview
Degraded

Booking.com - Elevated message send failures (404s)

May 7, 2026 at 8:00am UTC
Affected services
Booking.com API
Inbox
Guest experience

Resolved
May 8, 2026 at 3:23pm UTC

Booking.com team has confirmed that they have fixed this issue on their end.

Created
May 7, 2026 at 8:00am UTC

We are seeing an elevated rate of 404 responses from Booking.com when posting messages on behalf of hosts.

Roughly ​~10% of outbound messages to Booking.com are failing​: both automated (scheduled and event-based) and manual messages sent from the inbox. The remaining ~90% are sending normally.

This started around ​May 7, 08:00 UTC​. We've reported the issue to Booking.com support and their product team is actively investigating.