Web application down
Resolved
Mar 16, 2026 at 05:35pm UTC
We are fully back online.
Affected services
Updated
Mar 16, 2026 at 05:17pm UTC
We are back online again! The application might still feel a bit slow. We are keeping an eye on the systems and performance while everything recovers.
Affected services
Updated
Mar 16, 2026 at 05:10pm UTC
The Hospitable application is currently very slow as we are experiencing downgraded performance with our hosting provider. The engineering team is investigating
Affected services
Created
Mar 16, 2026 at 04:45pm UTC
Our web application my.hospitable.com is down, the engineering team is investigating.
Affected services