Elevated Vrbo delays
Resolved
Nov 19 at 02:40pm CET
This incident has been resolved.
Affected services
Updated
Nov 19 at 02:02pm CET
Our engineers have identified the issue and fixed it. Our services are now recovering as expected.
Affected services
Updated
Nov 19 at 08:56am CET
We are working with our partners to remedy the network issues. We're continuing to monitor delays and errors.
Affected services
Updated
Nov 18 at 04:04pm CET
We are continuing to monitor for any further issues.
Affected services
Created
Nov 18 at 10:18am CET
We have identified the issues showing an increase in delays and errors with VRBO, including messaging, reservations, and calendar. We are working on getting the network issues resolved.
Affected services