Back to overview
Downtime

Vrbo API changes - Partial information for Vrbo reservations delay

Jun 23 at 09:51pm CEST
Affected services
Vrbo API

Resolved
Jul 04 at 05:42pm CEST

This incident has been resolved.

The Vrbo reservation financials will be back soon, and we will update the Hospitable.com changelog once that is live.
At that time we will also refresh all past Vrbo reservations to be sure they are pulling in all of the financial data.

Changelog can be found here: https://changelog.hospitable.com/

Updated
Jul 01 at 02:40pm CEST

Fixes:
- We are now able to pull in the default check-in and check-out times for Vrbo listings, and all reservations previously impacted should now have the correct times.
- We are able to pull in the reservation total, subtotal, and cleaning fees

We're working on:
- Pulling in the rest of the financials.
- Pulling in the rest of the guest details: address, ratings/average rating, trip count, and URL.
- The guest picture is currently pulling in only some of the time.

Updated
Jun 30 at 08:55pm CEST

We are currently working on improving how check-in and check-out times are set for Vrbo guests to fix the current standing issue of pulling in the incorrect times.

Updated
Jun 28 at 05:18pm CEST

What has been fixed:
- The partial fix will allow us to again detect new Vrbo bookings, new booking status changes, new messages, and bookings / changes / messages that were previously not picked up due to this issue.
- Guest email addresses and phone numbers are now being pulled in for all new reservations booked after June 27th, 8:33am ET.
- We are now pulling in the total cost for reservations.
- General reduction in one-off errors.

What has not been fixed:
- At this moment we are still unable to pick up guest details other than first/last name and picture, for all reservations booked from the beginning of the incident to June 27th 8:33am.
- We are unable to pick up financial information other than the total for any new reservations since the start of the incident, and check-in / check-out times may be incorrect.
- This also means that any short codes or custom code restrictions included in messages to Vrbo guests which rely on this information will not work.
Short codes related to check in/out times, host name, listing address, etc will all continue to work though.

If your check-in or check-out times are incorrect, please manually update them in the guest conversation in our Inbox so that any messages dependent on that timing are sent correctly.

We will continue to update here with new information.

Updated
Jun 27 at 05:43pm CEST

What has been fixed:
- The partial fix will allow us to again detect new Vrbo bookings, new booking status changes, new messages, and bookings / changes / messages that were previously not picked up due to this issue.
- Guest email addresses and phone numbers are now being pulled in for all new reservations booked after June 27th, 8:33am ET.

What has not been fixed:
- At this moment we are still unable to pick up guest details other than first/last name and picture, for all reservations booked from the beginning of the incident to June 27th 8:33am.
- We are unable to pick up any financial information related to any new reservations since the start of the incident, and check-in / check-out times may be incorrect.
- This also means that any short codes or custom code restrictions included in messages to Vrbo guests which rely on this information will not work.
Short codes related to check in/out times, host name, listing address, etc will all continue to work though.

We will continue to update here with new information.

Updated
Jun 25 at 12:07am CEST

A PARTIAL fix has been implemented for this issue and we are monitoring the results.

What has been fixed:
- The partial fix will allow us to again detect new Vrbo bookings, new booking status changes), new messages, and bookings / changes / messages that were previously not picked up due to this issue.

What has not been fixed:
- At this moment are still unable to pick up guest details other than first / last name and picture, and we are unable to pick up and financial information related to the reservation.
- This also means that any short codes or custom code restrictions included in messages to Vrbo guests which rely on this information will not work.
Short codes related to check in/out times, host name, listing address, etc will all continue to work though.

We will continue to update here with new information.

Updated
Jun 24 at 04:56pm CEST

We are continuing to work on a fix for this issue.

Updated
Jun 24 at 04:55pm CEST

The issue has been identified and a fix is being worked on.

Created
Jun 23 at 09:51pm CEST

We are currently experiencing an elevated rate of errors from Vrbo as a result of some major changes that have been made to their API.

These changes are causing our system to not detect new reservations or new messages in existing reservations, and detecting changes to pre-existing reservations with a significant delay. This means that any alterations or cancellations cannot be changed or unblocked in a timely fashion in our system.

Our engineers have identified the changes and are currently working on improving our connection to account for these changes. We will update here with any improvements.

In the meantime, it is recommended that the dates for all new reservations be manually blocked in our calendar to avoid double-bookings.