Legacy Airbnb integration: No message sent, engineers mitigating the consequence of an Airbnb change. Please upgrade your Airbnb integration if you are affected.
Resolved
Nov 17 at 09:54am CET
This incident has been resolved.
Affected services
Updated
Nov 16 at 03:43pm CET
We see full resolutions across the board for users of our Legacy Airbnb integration.
- This issue only affected customers that are still on our Legacy integration (outside of our partnership with Airbnb). This has not affected any users are connected through Airbnb with our official integration that is progressively being released to our customers. Customers that want to be upgraded in advance of their scheduled roll-out can contact support@hospitable.com.
- This issue was caused by a reservation response format being retired from Airbnb (ie, Airbnb stopped using it), which allowed our application to update conversations. Without this format, we could not update conversations, but other operations were actually not impacted.
- Scheduled messages have been sent for reservations that were accepted before the incident window.. Scheduled messages have been sent for reservations that were accepted during the incident window (although delayed, some by several hours)
- Event messages (ie, triggered by a new inquiry or a new reservation) could not be sent during the outage window, and have been sent at once when we have deployed a fix to this incident, and when the last message was not sent by the host at the time the conversation was finally retrieved.
- During the incident window, no conversation with guests could be created or updated. We also did not send any push notifications. We did send emails notifying that a message was sent.
- Users could send messages from the inbox with conversations created before the incident window, but could not see the inbox being updated.
We apologize for the inconvenience that has caused to our customers. Our systems were able to preserve some critical functionality during this incident, which limited the impact to guests. However, reliability and trust are principles that we hold dear, and we have worked with Airbnb to ensure that we can build our product and features on a reliable infrastructure, where changes can be anticipated. We will ensure to speed up our roll-out plan for our upgraded Airbnb official integration, as we want to ensure we have capacity to onboard all users (property owners, property management companies) and give them time to move to our upgraded integration successfully.
Affected services
Updated
Nov 16 at 02:37pm CET
A fix has been implemented and we see operations resuming to normal for all conversations during this outage window.
Affected services
Updated
Nov 16 at 09:52am CET
This issue is related with a recent change on Airbnb's side affecting our legacy Airbnb integration.
While we are looking for a way to mitigate the consequences of this change, we recommend all customers affected to upgrade to the Airbnb official integration. Please reach out to support@hospitable.com if you have not done so already to ensure that you can resume your operations.
Affected services
Updated
Nov 16 at 09:49am CET
This issue is related with a recent change on Airbnb's side affecting our legacy Airbnb integration.
While we are looking for a way to mitigate the consequences of this change, we recommend all customers affected to upgrade to the Airbnb official integration. Please reach out to support@hospitable.com if you have not done so already to ensure that you can resume your operations.
Affected services
Created
Nov 16 at 04:48am CET
We're seeing that Airbnb is currently experiencing an elevated rate of errors when we send messages. We are monitoring the situation.
Airbnb may be experiencing technical difficulties. This may affect our operations until Airbnb is back to normal.
Affected services