Back to overview
Downtime
Web application down
Jun 04 at 11:08am CEST
Affected services
Inbox
Calendar
Resolved
Jun 04 at 12:58pm CEST
This incident has been resolved.
Affected services
Updated
Jun 04 at 11:19am CEST
A fix has been implemented and we are monitoring the results.
Affected services
Created
Jun 04 at 11:08am CEST
We are currently investigating an outage of the web application.
Affected services