Back to overview
Downtime

Support communication is currently down.

May 25 at 12:03pm CEST
Affected services
Live chat & email support, product tours and support documentation

Resolved
May 25 at 12:22pm CEST

This incident has been resolved.

Created
May 25 at 12:03pm CEST

The integration that we use for our support chat is currently experience issues and is down. Our customer support team will be able to answer your questions as soon as this integration is working again.