Message limits on Airbnb (official)
Incident Report for Hospitable.com
Resolved
We have stress-tested the rate limits that are provided by Airbnb, and we have ensured that they are up to our expectations. Our messaging limit are now 2 orders of magnitude greater than other software providers.

In turn, this means it's the best time to upgrade your account to our Airbnb official integration, and benefit from real-time messaging, and a greater quality of service. Happy hosting!
Posted Dec 02, 2021 - 17:01 UTC
Monitoring
We received confirmation from Airbnb a few hours ago that the rate limits have been increased accordingly. We are currently monitoring our messaging service and will provide a further update once confirmed that backend operations are back to normal.
Posted Dec 02, 2021 - 02:02 UTC
Update
Our development team implemented the necessary workaround so that scheduled messages are currently sent successfully. However, you can expect that some of the messages will be sent with a delay of a few minutes.

We received a response from the Airbnb API team that they will increase the rate limits for our messaging service, which will resolve the root cause of the incident. We are waiting for confirmation from them that the needed changes were made and the rate limits were increased.

Once we receive it, we will revert to our previous implementation so that there is no delay in sending messages. We will provide further updates as soon as our messaging service is again fully operational.
Posted Dec 01, 2021 - 09:17 UTC
Identified
We have identified that Airbnb is enforcing inappropriate rate limits for the Hospitable application. Only scheduled messages are impacted by this incident.

We have reached out to the Airbnb connectivity team to ensure that the correct limits are being used, which ensures that we can send the appropriate amount of message at the appropriate time.

In the meantime, our engineering team has taken measures to ensure that we can still send a high volume of scheduled messages. This includes delaying the messages by a few minutes to ensure the inappropriate rate limits are being complied with for the time being.

This incident is not affecting the usage of the inbox, or other features of the Hospitable application.
Posted Nov 29, 2021 - 13:36 UTC
Investigating
We're seeing a high rate of failures in sending messages for Airbnb guests. On the Hospitable interface, a message may be shown as sent successfully, but it is not seen in the thread and is not sent to the Airbnb platform.

Our Airbnb integration may be experiencing technical difficulties. This may affect our operations until Airbnb is back to normal.

We are investigating the root cause of the issue. We recommend managing your guest messaging directly in your Airbnb inbox in the meantime.
Posted Nov 28, 2021 - 07:55 UTC
This incident affected: Products & Features (Inbox, Guest experience) and Channels (Airbnb.com API).